Users browsing this thread: 1 Guest(s)
NDS model + animation => COLLADA converter
#16
Nice job Inferry, thanks! This is great; it worked for all the models I tested it on Thumbs Up
Reply
Thanked by:
#17
Hi there,

I've been trying to convert a set of nsbmd from the game "To Love-Ru", but I keep getting this error upon converting any of the models:



Code:
thread 'main' panicked at 'no entry found for key', src\libcore\option.rs:794
note: Run with `RUST_BACKTRACE=1` for a backtrace.

Not sure what I'm doing wrong? I can send a PM with a sample file if needed. It loads fine in the viewer so not right sure what might be going wrong.

Regards,
Tomix
Reply
Thanked by:
#18
No, that's definitely a bug on my end. I looked it over and I think this is probably because I forgot to handle the case where textures aren't found when I redid some texture stuff recently. I pushed a change to fix that. Download the new version and see it that works. If it doesn't,  could you paste the backtrace here for me? (On Windows, you just need to run set RUST_BACKTRACE=1 before you call apicula to get it.)
Reply
Thanked by:
#19
Looks like that fixed it. Thank you!
Reply
Thanked by:
#20
So i've been interested in ripping NDS models for a while, but i've never extracted them with bones before so this is really interesting to me! I extracted a model from The Legend of Zelda: Spirit Tracks, and the textures look messed up on the model. This issue does not appear when I use MKDS Course Modifier but the textures are mirrored, (to see what i mean look at the zip file). How do I fix this?

Apicula and MKDS Course Modifier Models: 
https://mega.nz/#!YYJ1HSAS!luX6yiA9KfWfw...MlO3kTm-vg 
Apicula Model: 
https://streamable.com/jz4p9
MKDS Course Modifier Model/How the model is supposed to look: 
https://i.imgur.com/b9tMdHz.png

EDIT: I just realized that it previews fine in the model viewer but I don't know how to make it look like that from blender
Reply
Thanked by:
#21
This is another issue with importing into Blender. Blender doesn't respect the wrap mode for textures in a COLLADA file. For example, the UVs for the eye on your model look like this (selected):

[Image: ZdbU51y.png]

The texture is supposed to be sampled in MIRROR mode, ie. the texture repeats in both directions and it's mirrored each time it repeats so that the eye is symmetric. But Blender ignores this setting. You can turn it on manually (it's under Images > Image Mapping in the Properties panel; toggle check boxes for Mirror X and Mirror Y) but also note that AFAICT this only affects the viewport in "Rendered" mode, not "Material" mode.

The reason MKDS works is that it "hard wraps" the image (see karada.png for what it looks like when mirrored in both directions) and then adjusts the texture coordinates to match. IIRC ConsoleTool does that too.
Reply
Thanked by:


Forum Jump:

Want to remove ads? Become a supporter for just $5 a month!