Users browsing this thread: 1 Guest(s)
PAK Ripping - Light : Fellowship of Loux
Light : Fellowship of Loux is a new mobile based game and they seem to have hidden all their data in .pak files. I was wondering if anyone could take a look at these and see if you can extract any image files and then explain how you went about doing it so I can rip the rest of the images. The model files would be nice to have but I'm mainly in need of the image files. This is a new game and in order to build up a wiki and some fansites, we need the image files. I'm not sure why they made it so hard to rip basic image files.

If anyone could take a look at these or point me in the right direction on how to extract the image files that would be great! I've searched on google for anything on how to go about ripping pak files but there is nothing, or I'm just not searching the right stuff.

Here are some dropbox links to a few of the pak files from the game.
Thanked by:

[Image: vyy77wH.png]

Don't be distracted by the .pak file extension; that's just a common way for game devs to say there's more than one file compressed into an archive.

These look to be Unity asset bundles; you can unpack them with Unity Assets Bundle Extractor. Not the most user-friendly of programs, but it gets the job done. You'll want to open the .pak file; it'll ask you to decompress; save it someplace. Then choose Info and sort by Type. Look for Texture2D; those are your images. Select them all->choose Plugins->export to .png and you're done. The act_arthur.pak here has some UV maps for some 3D models, the common.pak doesn't have any textures, and the cartoon7 has the above image.

Have fun!
Thanked by: xHighx
Wow, I honestly didn't expect it to be that simple... thank you very much!

for the act_arthur.pak I was able to extract the .obj and the texture files as .png's but they seem to have split the textures. I tried to export the "Material" files but there doesn't seem to be a plugin for them in the program. I tried to rename them as .mtl files but they don't seem to work. I also tried using Unity Studio but that doesn't seem to be mapping the texture properly. Any thoughts on how to get the texture material mapping?
Thanked by:
Looking at the .obj file, it's because the texture vertices themselves are incorrect:
[Image: n3ANchA.png]
Those "vt" lines are supposed to be texture coordinates, but they're all NAN or borked otherwise somehow.
I sure dunno what would cause that. It may be worth posting in the other forum if you want them extracted properly.
Thanked by:

Forum Jump: