Users browsing this thread: 1 Guest(s)
Dragon Ball Revenge of King Piccolo Texture problem (WII)
#1
Hi so i want to rip models from this game but I am unsure how to add face texture : http://imgur.com/CYpyvSx

All the face textures are in one file and im unsure how to seperate them and apply them to the model: http://imgur.com/YYKNxRv

Im new to this stuff so help would be appreciated.
Reply
Thanked by:
#2
I assume they're all in one file cause the developers probably just shifted the UV's in order to animate his different expressions.

So I wouldn't worry about separating em, applying the textures is dependent on what modelling package you're using, which google will lead you to plenty of ways to do it.

edit: If you'd like, upload the model with his textures and I could put em together in Blender for you. As well as show you how to do it yourself.
Reply
Thanked by: Howdareme
#3
(05-31-2016, 04:28 AM)Guy Wrote: I assume they're all in one file cause the developers probably just shifted the UV's in order to animate his different expressions.

So I wouldn't worry about separating em, applying the textures is dependent on what modelling package you're using, which Google will lead you to plenty of ways to do it.

edit: If you'd like, upload the model with his textures and I could put em together in Blender for you. As well as show you how to do it yourself.

Thanks you so much!


Attached Files
.zip   Goku.zip (Size: 239.81 KB / Downloads: 64)
Reply
Thanked by: Guy
#4
Well I have some good news and bad news.

Good: There's no problem importing the model, and applying the textures.
[Image: OpOeH3f.png]

Bad: The uv's for his face are non-existent, so we may need to ask someone for some help on this.

EDIT: I sent some PM's to a few people that may be able to help.
Reply
Thanked by: Howdareme
#5
I know why it's like that, the face uses UV layer #2 for whatever unexplained reason, I remember that from when I had looked at the same model a few years back. I'm not exactly sure how easy it'd be to swap those back to the proper setup in Maya or Blender, but I know how to do so in 3DS Max, so if you wanna wait a few days, I'll work on getting a proper extraction up on The Models Resource.
Reply
Thanked by: Guy, Howdareme
#6
(06-02-2016, 04:45 AM)Random Talking Bush Wrote: I know why it's like that, the face uses UV layer #2 for whatever unexplained reason, I remember that from when I had looked at the same model a few years back. I'm not exactly sure how easy it'd be to swap those back to the proper setup in Maya or Blender, but I know how to do so in 3DS Max, so if you wanna wait a few days, I'll work on getting a proper extraction up on The Models Resource.

I think we'd both appreciate it RTB, thanks for replying, I'd rather you didn't have to do it though, I know you got a lot of other side projects going on.

If it's possible a quick rundown of the process, when you get the chance, would probably suffice.
Reply
Thanked by: Howdareme
#7
(06-02-2016, 04:45 AM)Random Talking Bush Wrote: I know why it's like that, the face uses UV layer #2 for whatever unexplained reason, I remember that from when I had looked at the same model a few years back. I'm not exactly sure how easy it'd be to swap those back to the proper setup in Maya or Blender, but I know how to do so in 3DS Max, so if you wanna wait a few days, I'll work on getting a proper extraction up on The Models Resource.

Thanks alot, if you have time a tutorial would be nice in 3DS Max as there are other models that face this problem.
Reply
Thanked by:
#8
(06-02-2016, 08:43 AM)Howdareme Wrote: Thanks alot, if you have time a tutorial would be nice in 3DS Max as there are other models that face this problem.
It's quite easy in 3DS Max. Make a copy of the problematic polygon group, then go to the last tab (Utilities) and click on the "More" button in the top-left. Pick the "Channel Info" option, and click on "OK". A new option will show up on the bottom of the pane with the same "Channel Info" name. Click on that, and in the window that pops up, look for the "2:map" ID group, right-click that and copy, then right-click on the "1:map" above it and paste over it. Click on "OK", and then the UV mapping will change.

Then just apply the face texture to that fixed polygon group, and delete the polygons that aren't for the face (basically everything around the "hole" on the original, they'll be bunched up in one spot on the UV mapping), and you should be good to go.
Reply
Thanked by:
#9
(06-02-2016, 09:10 AM)Random Talking Bush Wrote:
(06-02-2016, 08:43 AM)Howdareme Wrote: Thanks alot, if you have time a tutorial would be nice in 3DS Max as there are other models that face this problem.
It's quite easy in 3DS Max. Make a copy of the problematic polygon group, then go to the last tab (Utilities) and click on the "More" button in the top-left. Pick the "Channel Info" option, and click on "OK". A new option will show up on the bottom of the pane with the same "Channel Info" name. Click on that, and in the window that pops up, look for the "2:map" ID group, right-click that and copy, then right-click on the "1:map" above it and paste over it. Click on "OK", and then the UV mapping will change.

Then just apply the face texture to that fixed polygon group, and delete the polygons that aren't for the face (basically everything around the "hole" on the original, they'll be bunched up in one spot on the UV mapping), and you should be good to go.


Sorry to trouble you, but if you have time could you provide screenshots as im pretty new to all of this stuff. Thanks though!
Reply
Thanked by:
#10
(06-02-2016, 02:01 PM)Howdareme Wrote: Sorry to trouble you, but if you have time could you provide screenshots as im pretty new to all of this stuff. Thanks though!
I'll work on that tomorrow morning. Smile
Reply
Thanked by: Howdareme
#11
Well i converted the .psk to a .obj, .fbx, and a .dae, using Noesis.

None of the 3 has a 2:map when I open em up with 3DS Max.

[Image: SNsOknm.png]

Is there another step beforehand that we need to do with the .brres?
Reply
Thanked by:
#12
(06-02-2016, 03:04 PM)Guy Wrote: Well i converted the .psk to a .obj, .fbx, and a .dae, using Noesis.

None of the 3 has a 2:map when I open em up with 3DS Max.

*image*

Is there another step beforehand that we need to do with the .brres?
Oh, I forgot to mention you'll need to use BrawlBox to export it to a DAE, since it supports multiple UV mapping layers.
Reply
Thanked by: Guy
#13
Alrighty, that was a bit of a chore

- got the .bin files, wouldn't open with brawl box, opened in hex edit, deleted the data at the start up to where it says "bres" in the file.
- renamed file to .brres, it opened just fine in brawl box, but no textures, so i exported the model to .dae, UV channels were in tact
- opened same file in brres viewer, exported textures (Because the textures on The Textures Resource don't have transparency for some reason...)
- Imported .dae into blender, applied textures, the uv channels RTB mentioned in 3DS Max can be found in Blender in the Object tab under "UV Maps"
- Tinkered a bit with the textures, put it all together and it seems to be a pretty solid now. Content

I'll do a much better/thorough explanation tomorrow, with pictures to follow along with as well.

Also, the animating faces with UV offsetting I mentioned earlier:
[Image: Fl5NfVj.gif]
Reply
Thanked by: Howdareme


Forum Jump: