Users browsing this thread: 1 Guest(s)
I can't upload .zip files
#1
The last couple days, when I try to submit .zip archives I get "Error: Sheet must be an image or zip archive." As previously stated, they ARE zip archives. This happens on Spriters Resource and Sounds Resource at least, because those are the ones I tried recently, but probably also applies to the others.
Reply
Thanked by:
#2
This comes up every once in a while so I'll lead with the usual three questions:

1. What are you using to create the archive?
2. What browser are you using?
3. Do you have AdBlock (or an equivalent) installed?

I'd really like to get to the bottom of this so I also added some debug information to the error message. When you have a chance, without making any changes to your process, please try again and copy the error you get here.

Also, for what it's worth, I did reply to your email but, for some reason, your mail provider has our mail server blacklisted. I've contacted them to get it removed but that's why you didn't hear back from me.
Reply
Thanked by:
#3
(10-30-2015, 08:15 AM)Petie Wrote: This comes up every once in a while so I'll lead with the usual three questions:

1. What are you using to create the archive?
2. What browser are you using?
3. Do you have AdBlock (or an equivalent) installed?

I'd really like to get to the bottom of this so I also added some debug information to the error message. When you have a chance, without making any changes to your process, please try again and copy the error you get here.

Also, for what it's worth, I did reply to your email but, for some reason, your mail provider has our mail server blacklisted. I've contacted them to get it removed but that's why you didn't hear back from me.

That's weird. Why would it be blacklisted? Anyway, here's the answers:

1. I am using WinRAR. I've submitted zip archives made with it before, and they've been uploaded fine until recently.
2. I use Firefox. Again, I've been using Firefox exclusively for a while, and it's worked until recently.
3. I have AdBlock Plus installed. I know that ads are necessary for a site, but I needed it for one simple reason: ads were eating up my system processes and causing my computer to slow down and freeze. And, once again, I've had it installed for a long time and never affected uploading until recently.

I can try and disable AdBlock or use Internet Explorer (ugh) to upload.

UPDATE: Okay, here's the situation: disabling AdBlock doesn't help. However, it works if I upload through Internet Explorer. It appears to be a Firefox problem.
Reply
Thanked by:
#4
I still need that error message from Firefox if you don't mind.
Reply
Thanked by:
#5
Here's what it says:


Quote:Error:
Sound must be a zip archive.
  Debug: Reported Type = text/plain
Reply
Thanked by: Petie
#6
Thanks. That raises more questions than it answers though, unfortunately. I can't imagine why Firefox would report the zip as a plain text file. I'll look into it though.
Reply
Thanked by:
#7
Just in case it wasn't clear, image files (at least .png) do upload properly, it's only archives.
Reply
Thanked by:
#8
Yeah, that's what I figured. When this issue pops up, that's usually the case. I was hoping Firefox just sent a different type string but the fact that it's reporting as text/plain is really throwing me for a loop.
Reply
Thanked by:
#9
I just tested it with the same file (from this thread) and it works fine, using Firefox 41.0.2 without AdBlock. Just to make sure that the issue is on Teridax's side and not something with the ZIP itself. Maybe it's your version of FF though, have you tried checking for updates?
[Image: dilbert.gif]
Sprites ~ Sounds
You may have a fresh start any moment you choose, for this thing that we call "failure" is not the falling down, but the staying down. -Mary Pickford
Reply
Thanked by: Petie
#10
This seems to be a known issue with Firefox and the way it handles storing filetype associations based on user preferences for downloaded files. Unfortunately, there's literally nothing I can do to rectify it on my end so the only thing I can suggest is to switch to a different browser if this particular issue arises for you.
Reply
Thanked by:
#11
Sorry for reviving this old topic, but I'm having this problem again.
Reply
Thanked by:
#12
The solution is the same as it always has been. It's impossible to detect every type of encoding a browser might mark a zip as and I can't just arbitrarily allow any file types through. If you're getting this error again, please try it from a different browser.
Reply
Thanked by:
#13
the zip might be too big maybe? ive had that only come up when i exceed the upload limit size
Reply
Thanked by: Petie
#14
That's possible as well but it also occasionally happens when the browser reports an incorrect filetype causing the server to reject it outright.
Reply
Thanked by:
#15
I’m having troubles myself:

Here’s what I get:

Error:
Sound must be a zip archive.
Debug: Reported Type =


I’ve got a Mac OS X 10.8.5 (12F45), and I’ve tried uploading a sound file via Chrome for “Star Wars: Obi-Wan.” It’s in the pending stages, but this file is for the ambient sounds.
Reply
Thanked by:


Forum Jump: