Users browsing this thread: 1 Guest(s)
New Login System!
#1
Hello everyone!

Remember a little while back when I said I was working on some new cookie-related features? Well, the purpose of that was to simplify the login process for one of our upcoming new features. When that didn't work, I started doing some research and the result was an entirely new login system.

First, the link: http://www.vg-resource.com/login/

This is now a single sign-on system so logging in once will immediately log you into all five sites! Give it a try and stay tuned for the new feature that spurred the development of this new system!
Reply
#2
Thank you! This is a great feature, as now we no longer have to log into each individual portion of the site!
Reply
Thanked by: senjen
#3
I don't think it works on Internet Explorer. I just installed Firefox and it's working on that browser.
The future of things to come...
NID - LDEJRuff
3DS FC - 1349-9258-6921
Switch FC - SW-6321-5752-9422
Reply
Thanked by:
#4
Admittedly, I haven't had a chance to test in IE yet. I'll definitely look into it though.
Reply
Thanked by:
#5
(08-01-2014, 12:32 AM)LDEJRuff Wrote: I don't think it works on Internet Explorer. I just installed Firefox and it's working on that browser.

Here's a tip: Don't use Internet Explorer.
Reply
#6
IE 11 is actually decent and encouraged or not, a large number or people (11% of our recorded visits over the last month) still rely on IE so making login work for it is definitely something that needs to be done if it is, in fact, currently broken. If appreciate some other people testing and reporting back with their results and the version of IE they're using.
Reply
Thanked by:
#7
IE 11.

I logged in through the link you posted. I was only logged into the forum and could not in any way log into any of the resources.
Reply
Thanked by:
#8
Just tried it on whatever Internet Explorer comes with Windows 8.1. I could login on the forums themselves just fine. However, attempting to login on a resource would bring me to a page that said "click here to return to the site you logged in from". A split second later, I am redirected back automatically just as I should be, but I am still not logged in.
Reply
Thanked by:
#9
The page you're seeing is correct - that message is there in case the auto-redirect fails. That page is supposed to log you into the other sites though so I'll need to investigate why it isn't. My assumption is that it's redirecting too quickly and not allowing enough time for the login to happen. Thanks, both of you, for your reports just fine. Also, 8.1 should have 11 on it, just in case you were curious.
Reply
Thanked by: UploadingShitOnly
#10
Double posting to update - I think I fixed the issue with IE. The problem is that the login cookies for everything but the VG Resource were being rejected as "third-party" cookies. I played with the code a bit and tested and it now seems that login in IE is working correctly. If you two (or anyone else) would be willing to re-test (after clearing cookies in IE, of course), that would be awesome!
Reply
Thanked by:
#11
Logged in through the link and I'm logged into the forum and all the resources. Buuut, when I click Log Out on any of the resources, only the forum gets logged out. The resources stay logged in.
Reply
Thanked by:
#12
Oops... I was so focused on making login work that I completely overlooked the fact that logout would require the same fix. I just updated the logout code and while I haven't tested it just yet, it should be working now. Thanks!
Reply
Thanked by:
#13
Yes, all works fine. Well done.
Reply
Thanked by:
#14
whoa I thought ie's main function was to download another browser. I'm truly mind blown, that thing can be used to browse the internet omg omg omg. JK
[Image: flags_0]
Reply
Thanked by: DarkGrievous7145


Forum Jump: